Another kaffe 0.9.1 failed assertion

Kent Ryhorchuk ryhorchu at
Mon Jul 28 04:13:00 PDT 1997

Hello again all,

The assertion failed problem I previously mentioned went away when I changed
compiler and assembler. I had been using gcc version 2.5.8 with the HP 700/800
series asembler (as). HP's assembler did not like some of the directives in
the parisc thread switching code. Now I am using gcc version and
GNU assembler version 2.7 and it seems to work ok.

However, I have now encountered a new failed assertion:

./intrp/machine.c:184: failed assertion `npc < meth->c.bcode.codelen'

This happened when I tried to download byte code from a http conection and
call a method in it. The ClassLoader I used to do this worked fine with Sun's
VM on Solaris.



Jul 24 10:33 1997

To:        'kaffe at' (BNR400)

From:      Kent  Ryhorchuk                :1R21    (BNR)      SKY     BNR

Subject:   kaffe 0.9.1 failed assertion


I have been trying to get kaffe 0.9.1 running on HP-UX 9.05 on a HP 712/100
machine. This configuration is not supported in the kaffe distribution. I had to
configure kaffe with the --enable-staticlib option in order to make it compile.
Once built the vm failed horribly, spitting out the message:

bash-2.00$ kaffe HelloWorldApp
gc-mem.c:164: failed assertion `blk->magic == GC_MAGIC'
ABORT instruction

Does anybody have a clue what I might have done to cause this?

Kent Ryhorchuk.                                                                                                                                     

More information about the kaffe mailing list