kaffe and biss-awt

Andrew Pimlott pimlott at abel.MATH.HARVARD.EDU
Mon Mar 10 15:41:56 PST 1997

I hate to ask this, because it must come up a lot, but I can't find any 
answer elsewhere.

I just compiled kaffe 0.8.2 with the biss-awt package (the version that
was on the kaffe ftp site and said it went with 0.8.2) on Linux.  Hello
world ran fine.  When I first tried to use an AWT app, I came across an 
egregious bug--it couldn't find the awt shared library.  I found I had to 
create a link called libkaffe_awt.so pointing to libkaffe_bissawt.so.  
When I fixed this and tried again, I got:

Failed to locate native function:
        at sun/awt/motif/MToolkit.<init>(41)
        at java/awt/Toolkit.getDefaultToolkit(190)
        at java/awt/Window.getToolkit(155)
        at java/awt/Frame.addNotify(82)

This seems like it must also be a pretty simple problem, but I don't know
how to track it down.  I've set my environment exactly as given in the 
documentation (I also tried adding biss.zip to my classpath).  Can anyone 
help?  Are other people using kaffe 0.8.2 with the biss-awt?

Also (and this may be asking too much at this point!), would anyone mind
giving an overview of how using the biss-awt for the java.awt classes is
achieved?  I've looked at the sources in the biss-net.com directory, but
it's not clear to me what is straight from biss, what is additional, and
what is modified.


More information about the kaffe mailing list