Kaffe 0.9.0 strangeness

Mirian Crzig Lennox mcl at bronze.lcs.mit.edu
Fri May 30 22:50:03 PDT 1997

Hi all... perhaps someone here can explain this strangeness.

I just built Kaffe 0.9.0 on my '486 RedHat Linux 4.1 system.  Upon
running the HelloWorldApp program, I immediately get the message:

Library load failed: File not found

Then kaffe churns for a while with lots of disk activity (presumably
loading classes) and finally prints:

Hello World!

Using the javac script on HelloWorldApp.java gives the same error
message, but successfuly produces a valid, runnable
HelloWorldApp.class file.

So... I'm confused.  Kaffe *seems* to be working fine, except for the
initial error message.  I suppose I could simply ignore it, but I'm
hoping that someone here has run into it and can tell me what it could
be symptomatic of.

And by the way, this is not the same error message as
"kaffe: can't load library 'libkaffe_vm.so'", which I had gotten
previously, before I set my LD_LIBRARY_PATH properly.

Anyway-- any wisdom would be greatly appreciated!


More information about the kaffe mailing list