Kaffe intrp broken! (was Re: Kaffe-1.0.b1 for SunOS4)

Jake Hamby jehamby at lightside.com
Sun Jul 19 11:31:27 PDT 1998

On Sun, 19 Jul 1998, Raffaele Sena wrote:

> On Sun, 19 Jul 1998, Kiyo Inaba wrote:
> > 1. Compiler pizza.compiler.Main does not work.
> > On SunOS 4.1.4/gcc-2.8.1
> > 	Kaffe sun.tools.javac.Main HelloWorldApp.java
> > works fine, but
> > 	Kaffe pizza.compiler.Main HelloWorldApp.java
> > produces error as,
> > 	HelloWorldApp.java:2: cannot access class String; bad class file (java.lang.NullPointerException: null)
> > 		public static void main (String args[]) {
> This is exactly the error I was getting on my arm/linux port.
> And it ended up to be a wrong cast from Java int to Java char
> (cutting off the top 8 bits).
> The error was only in the interpreter ( intrp/icode.h: cvt_int_char ),
> while the translator ( jit/icode.c: cvt_int_char ) seems to do the
> right thing, unless sizeof(jchar) is not 2.

Ah ha!  Thanks for the info.  I tried to compile without the JIT on
SPARC/Solaris to see if I could figure out the cause of the Bean test
failure on that platform, and I ran into the interpreter bug.


More information about the kaffe mailing list