bug in finalizer?

Alexandre Oliva oliva at dcc.unicamp.br
Mon Oct 12 00:27:13 PDT 1998


The attached program will stop running the finalizer after collecting
some objects, for some reason I couldn't find out :-(

This is on Kaffe 1.0.b2, tested on Solaris/Sparc and Linux/x86.

I have tried to move the definition of finalRunning=false to just
after the wait, instead of just before it, and I'd only enter the wait 
if finalRunning was false.  I also tried to modify GCfinish so that it 
would broadcast the condition of finman, instead of just signalling
it, but none of this produced any visible effect.

Unfortunately, I won't be able to pursue this bug in the next two
weeks, since I'm leaving for a trip tomorrow.

Does this ring a bell for anyone?

Alexandre Oliva
mailto:oliva at dcc.unicamp.br mailto:oliva at gnu.org mailto:aoliva at acm.org
Universidade Estadual de Campinas, SP, Brasil
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.java
Type: application/octet-stream
Size: 166 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/19981012/68900825/attachment-0007.obj 

More information about the kaffe mailing list