Problems w. Compiling on WinNT

ahalbri2 at ahalbri2 at
Wed Aug 11 00:38:29 PDT 1999

I tried to compile Kaffe 1.0b4 on a Windows NT machine using Cygwin B.20.
Having renamed a directory from 'cygwin32' to 'cygwin' the configure script
worked properly.

Unfortunately I got an error while executing the make command.
The error message looked like this:

Making all in native
/bin/sh ../../../libtool --mode=link gcc  -g -O2 -Wall -Wstrict-prototypes
-o -rpath /usr/local/lib/kaffe  -module -release 1.0b4
-export-symbols-regex "^([Jj]ava|kaffe)_"
ObjectStreamClassImpl.lo sha-1.lo ClassLoader.lo Class.lo Compiler.lo
Double.lo Float.lo Math.lo Object.lo
Runtime.lo SecurityManager.lo String.lo System.lo Thread.lo Throwable.lo
CharToByteDefault.lo ByteToCharDefault.lo ZipFile.lo MemoryAdvice.lo
Array.lo Constructor.lo Field.lo
Method.lo DateFormat.lo TestNative.lo -lm
libtool: link: warning: undefined symbols not allowed in i686-pc-cygwin
shared libraries
rm -fr .libs/ .libs/libnative.* .libs/libnative-1.0b4.*
ar cru .libs/libnative.a  ObjectStreamClassImpl.o sha-1.o ClassLoader.o
Compiler.o Double.o Float.o Math.o Object.o Runtime.o SecurityManager.o
System.o Thread.o Throwable.o UNIXProcess.o CharToByteDefault.o
ZipFile.o MemoryAdvice.o Array.o Constructor.o Field.o Method.o
DateFormat.o TestNative.o
ar: ObjectStreamClassImpl.o: No such file or directory
make[3]: *** [] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all-recursive] Error 1

Does anyone know a solution for this problem?


More information about the kaffe mailing list