Kaffe built statically on SunOS4.1.3_U1 - some questions

Godmar Back gback at cs.utah.edu
Mon Jan 4 12:24:07 PST 1999

> Archie Cobbs <archie at whistle.com> wrote:
> > Joe Hartley writes:
> > > First, I get as far as the UDPTest when I run "gmake test", then everything
> > > just seems to freeze.  Is there a known problem with this test under SunOS?
> > 
> > It may take a while if you have a broken DNS setup.. not more than
> > a few minutes though.
> My DNS is OK both forward and reverse.  (I'm my own ISP, so I have full
> control over this :)  Since the UDPTest.java code simply seems to use
>, this should go quickly.  I killed it last night after waiting
> 10 minutes for something to happen.
> > Regarding the other problem, are you using 1.0b3 or the latest
> > repository snapshot?
> This is with 1.0b3.  I tried compiling the snapshot last night, but it
> died trying to compile libraries/clib/native/CharToByteDefault.c:
> gcc -I. -I../../../include -I./../../../include -I../../../config 
> -I./../../../config -I/usr/local/include -g -O2 -Wall -Wstrict-prototypes 
> -o CharToByteDefault.o
> In file included from ../../../include/jni.h:18,
>                  from CharToByteDefault.c:15:
> ./../../include/jmalloc.h:20: warning: parameter names (without types) in function declaration
> ./../../include/jmalloc.h:22: parse error before `size_t'
> ./../../include/jmalloc.h:22: warning: function declaration isn't a prototype
> Apparently gcc2.7.2.3 doesn't like this line in include/jmalloc.h:
> extern void*    jrealloc(void*, size_t);
> It looks OK to me, but GCC disagrees!

 size_t has to be defined somewhere.
I guess it needs a #include <stdlib.h> or #include "config-std.h"
somewhere.  Try including "config-std.h"  in CharToByteDefault.c

	- Godmar

More information about the kaffe mailing list