missing files, while compile Kaffe

Mansuroglu Seki man at iis.fhg.de
Mon Aug 14 06:17:31 PDT 2000

 Hallo Archie,
 thank you for your tips. I tried building Kaffe again. I performed following

- Download setup.exe from cygwin and all GNU-packages they are supported (Is it
OK ? Do I need to intall automake or autoconf from GNU).
- copy kaffe-1.0.6 in the same directory as setup.exe.
- execute setup.exe with 'd:\cygwin' as the install directory.
- start cygwin bash shell.
- cd to ''
- run './configure'. (I didn't receive any errors. After it  only the following
header-files were created:
The three java_lang-files were not created.)
- cd to 'd:\cygwin\kaffe\kaffe\kaffe'
- run make (the same error)

Did I follow the right way?

Thanks. Seki.

Archie Cobbs schrieb:

> Mansuroglu Seki writes:
> > ../kaffevm/thread.h:19: java_lang_Throwable.h: No such file or directory
> >
> > ../kaffevm/thread.h:20: java_lang_Thread.h: No such file or directory
> > ../kaffevm/thread.h:21: java_lang_ThreadGroup.h: No such file or
> > directory
> > make: *** [main.o] Error 1
> These files are not part of the distributed source, but they
> get generated during compile time. You should see a bunch of
> header files generated using kaffeh and Klasses.jar before
> the build gets to this point.
> Hmm.. try building again in a completely fresh build tree and
> check the earlier portion of the build log for any errors..
> -Archie
> ___________________________________________________________________________
> Archie Cobbs   *   Whistle Communications, Inc.  *   http://www.whistle.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: man.vcf
Type: text/x-vcard
Size: 357 bytes
Desc: Visitenkarte für Mansuroglu Seki
Url : http://kaffe.org/pipermail/kaffe/attachments/20000814/52c2cf59/attachment-0003.vcf 

More information about the kaffe mailing list