File.getAbsolutePath() bugfix

Mike Linksvayer ml at
Fri Jan 14 02:23:20 PST 2000

On Thu, Jan 13, 2000 at 02:37:13PM -0500, Mike Linksvayer wrote:
> Argh, please unfix.  I'm an idiot ... the behavior of getAbsolutePath()
> is correct, only getCanonicalPath() is incorrect.  I'll post a real
> fix tonight, after I've tested more thoroughly.

It happens that getCanonicalPath was fixed on January 4.  Luck
would have it that I was working with code I retreived on January
3.  I had assumed that cvs diff would give me differences between
the head revision and my file, but apparently it gives the differences
between the revision I have checked out and my file ... I haven't
used cvs in two years. :(

Now I've encountered another problem:  Process.destroy() causes
kaffe to exit without a stack trace and without a core file.  The
following simple program never prints "destroyed" on my system
(Debian 2.1, kernel 2.2.1, gcc

public class destroy {
    public static void main(String[] args) {
        try {
            System.err.println("starting process");
            Process p = Runtime.getRuntime().exec("sleep 5");
            System.err.println("started process, destroying");
            System.err.println("destroyed process");
        } catch (Throwable t) { t.printStackTrace(); }

I haven't tried running in gdb yet.

Another question:  Is it safe to use gcc 2.95? says egcs is not ok, but that's
dated 4/99, and I've read about experimental gcj support which
obviously would require egcs.  I ask because I've tried very briefly
to compile and run kaffe on Solaris and Suse systems and egcs with
bad results.

                              See From: and Organization: above.

More information about the kaffe mailing list