kaffe wont' recognize that gmp is installed

sipher   sipher42 at hotmail.com
Tue Nov 7 09:27:57 PST 2000

Ok I think I guessed at what this does even thoguh I could get this diff 
command to work.  I just whent in and manually added all the things you have 
with a + next to it inbetween the indicated lines
I did a make clean.  I ran autoconf in my Kaffe dir.  I removed config.cache 
and I ran ./configure  My end result is still [root at rootdown kaffe-1.0.6]# 
grep gmp config.cache

I assume that means that its' still not finding this function or whatever it 
is.  Did I miss something?  Am I doing something wrong?  What shoudl I do 
now?  Thanks for all your help.

----Original Message Follows----
From: "Edouard G. Parmelan" <Edouard.Parmelan at quadratec.fr>
Reply-To: kaffe at rufus.w3.org

Well, thanks for that, GMP 3 rename function mpz_get_d to __gmpz_get_d.
If you have autoconf 2.13, apply this patch:

diff -u -r1.147 configure.in
--- configure.in        2000/07/24 19:58:35     1.147
+++ configure.in        2000/11/07 11:51:23
@@ -597,6 +597,10 @@

  dnl Check for libraries for math library.
+if test $ac_cv_lib_gmp_mpz_get_d = no; then
+  dnl with gmp3 it's a #define, use real function name
+  AC_CHECK_LIBRARY(gmp,__gmpz_get_d,MATH_LIBS)

And run autoconf.

     $ autoconf

Hope this helps -- this will be in CVS Tree in a near futur.
Edouard G. Parmelan

Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

Share information about yourself, create your own public profile at 

More information about the kaffe mailing list