Problems when building Kaffe on WINNT

??? mtkkorea at
Wed Jun 27 16:44:58 PDT 2001

In  My case, My host machine is Linux.
And In this case(The failure was caused by "undefined reference" to those function defined in "zlib.h".), zlib library is required.
I think you must install zlib library..

For your success.. 
  -----Original Message-----
  From: owner-kaffe at [mailto:owner-kaffe at]On Behalf Of Congchun He
  Sent: Thursday, June 28, 2001 5:42 AM
  To: kaffe at
  Subject: Problems when building Kaffe on WINNT

  Dear Sir,

  I tried to build Kaffe-1.0.6 on WINNT 4.0.
  According to the instruction, I installed CYGWIN firstly, and then ran configure for kaffe. So far, it
  worked well. 

  But when I tried to compile the source codes using command "make", it invokes a lot of errores which
  were caused by the absent header file "windows.h".  

  So, I added a line in config-std.h to include "windows.h" and re-compiled the codes. Well, this time, it 
  could compile most of modulars but still failed at the directory Kaffe-1.0.6\kaffe\kaffe which would build 
  kaffe.exe. The failure was caused by "undefined reference" to those function defined in "zlib.h".

  The error message looked as:
  "gcc -g -O2 -Wall -Wstrict-prototypes -o Kaffe.exe main.o version.o .libs/Kaffe.e
  xeS.o -Wl,--export-dynamic  -L/usr/local/lib ./../libraries/extensions/microsof
  t/clib/.libs/libmicrosoft.a ./../libraries/clib/security/.libs/libsecurity.a .
  /../libraries/clib/management/.libs/libmanagement.a ./../libraries/clib/math/.l
  ibs/libmath.a -lz ./../libraries/clib/zip/.libs/libzip.a ./../libraries/clib/i
  o/.libs/libio.a ./../libraries/clib/net/.libs/libnet.a ./../libraries/clib/nat
  ive/.libs/libnative.a ./kaffevm/.libs/libkaffevm.a ./xprof/.libs/libkaffexprof
  .a -Wl,--rpath -Wl,/usr/local/lib
  ../../libraries/clib/zip/.libs/libzip.a(Adler32.o): In function `java_util_zip_A
  file://f/temp/kaffe-1.0.6/libraries/clib/zip/Adler32.c:24: undefined reference to `ad
  ../../libraries/clib/zip/.libs/libzip.a(Adler32.o): In function `java_util_zip_A
  file://f/temp/kaffe-1.0.6/libraries/clib/zip/Adler32.c:33: undefined reference to `ad

  Would you mind telling what can be done to fix such a problem?

  Thanks a lot.

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the kaffe mailing list