StrongARM Kaffe configured , but incorrect.

shsun01 shsun01 at
Sun Nov 25 23:28:57 PST 2001

I want to make a ARM Kaffe to put on StrongARM's machine.
At first,I make a X86's kaffeh successfully.
Next i changed environment varables ,i Configured it
,it was successful. Next Step is the "make clean"  and
moved executable kaffeh to  "linux/jvm/kaffe/kaffeh", and
"make;make install",it looks like no problem.

Then i tried it on arm-linux platform, so i used
minicom connect to arm that booted by flash rom.
and used ethernet network mount my make results for Linux OS of ARM.

ok ,when it done ,I compiled a very simple java program "$javac",it takes about 10 minutes,
but it accomplished, I got the HelloWorld.class .
When i executed the result "$java HelloWorld", it
would run for a long time , and return error message:


i confused , because about this message my experience is CLASSPATH not found.
but when i modified /mnt/kaffe/bin/kaffe and appended "echo $CLASSPATH",i can
see all of the jar files in /mnt/kaffe/share/kaffe showed.

second,why it so slowly even i tried "$/mnt/kaffe/bin/kaffe HelloWorld" . 
what kind of issue cause this situation,OS memory,or Make error.....???

best regards

----------platform -----------------------------------------------------------------------
StrongARM based machine : applieddata 's Graphic Master
flash ROM:32MB (kernel 2.2.

--------environment variable setting of mine -------------------

My conifgure plateform is X86 RedHat linux 2.2.17,
configure command is ./configure --prefix=/mnt/kaffe
--build=i386-linux host=arm-linux --without-x

i changed my environment variables for arm
./bash_profiel changed to 
export CC=arm-linux
export GCC='arm-linux-gcc -E'
export AR=arm-linux-ar
export LD=arm-linux-ld
export STRIP=arm-linux-strip
export OBJCOPY=arm-linux-objcopy
export OBJDUMP=arm-linux-objdump
export RANLIB=arm-linux-ranlib
and source ~root/.bash_profile

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the kaffe mailing list