[kaffe] OpenBSD issues

benn fsnews at antimouse.com
Wed Aug 21 11:25:59 PDT 2002


	I've just recently had a need to run Java on an OpenBSD server, however I 
have not had any success with getting Kaffe working.  I've tried this out 
on two different systems (one OpenBSD 3.1 and the other OpenBSD 3.0) and 
tried both the OpenBSD port version of Kaffe 1.0.6 as well as the latest 
1.0.7 release from the Kaffe site. Both port versions install fine, but 
when I go to run java I get the following error:

[benn at web]: /usr/local/bin/java
/usr/libexec/ld.so: Kaffe: libX11.so.6.2: No such file or directory

	Which makes me think that X Windows needs to be installed (it's not on 
either system). I'm not planning on running any Java apps with a GUI and 
I'd rather not install X on these systems. Is there a way to compile Kaffe 
without X Windows support?

	For version 1.07, here's the error line from "make" when it stops on 
OpenBSD 3.0:

gcc -g -O2 -Wall -Wstrict-prototypes -o .libs/kaffe-bin main.o version.o 
.libs/kaffe-binS.o  -L../kaffevm/.libs -lkaffevm -L/usr/local/lib -lm 
-Wl,-rpath,/usr/local/kaffe/jre/lib/i386 -Wl,-rpath,/usr/local/lib
main.c:313: Undefined symbol `_kaffe_dprintf' referenced from text segment

	If anyone has any suggestion for getting either version to work, please 
let me know.

Thank you,

More information about the kaffe mailing list