[kaffe] Crash

Dalibor Topic robilad at yahoo.com
Mon Jul 15 03:16:46 PDT 2002

Hi Matthew,

--- Matthew Toseland <mtoseland at blueyonder.co.uk>
> $ java freenet.node.Main --paramFile
> /etc/freenet-unstable/freenet.conf
> kaffe-bin: jthread.c:1748: handleIO: Assertion
> `(__extension__
> ({register char __result; __asm__ __volatile__ ("btl
> %1,%2 ; setcb %b0"
> : "=q" (__result) : "r" (((int) (i)) % (8 * sizeof
> (__fd_mask))), "m"
> ((( &readsPending)->__fds_bits)[((i) / (8 * sizeof
> (__fd_mask)))]) :
> "cc"); __result; }))' failed.
> Aborted
> Today's CVS, similar results from a few days ago's
> CVS, and 1.0.7[-rc1].
> Anything I can do to help debug this?

Thanks for your bug report. I've just tried out
freenet myself (build 485) using the snapshot from
20020714. NodeInfoServlet as well as surfing the
freenet to Da gj's free site worked for me on the
latest version from kaffe's cvs on i386-linux. What
platform are you running on? Could you send me the
contents of your freenet.conf file?

you could try to reonfigure kaffe with --enable-debug,
recompile and then try to find out what's happening
using the -vmdebug options for threads.

best regards,

dalibor topic

Do You Yahoo!?
Yahoo! Autos - Get free new car price quotes

More information about the kaffe mailing list