[kaffe] Problems getting started with Kaffe

Svante Arvedal svaar968 at student.liu.se
Fri Jun 28 04:32:22 PDT 2002

We're trying to install Kaffe on an Itanium machine running Red Hat Linux 7.2 ia64. We had great difficulties with installing kaffe, the makefiles unsuccessfully tried to make directories for example. We had to create the directories manually. Libtool also caused some problems. 
We were finally able to install, but running javac on a .java-file gives us a segmentatinon fault. The classpath doesn't seem to set automatically so we've tried to set it manually according to the kaffe script, with all the jar files and . and everything. We're not sure we got it right though.

We get the segmentation fault in external.c in method loadNativeLibrary2:

    	if (lib->desc == 0) {
    		if (status == TRY_LOAD_NOT_FOUND) 
    			snprintf(errbuf, errsiz, "%s: not found", strrchr(path, file_separator[0]) + 1);
    		errbuf[errsiz - 1] = '\0';
    		return -1;
errbuf[ .. ] gives a seg fault because errbuf is 0x0

Does anyone have any ideas?

More information about the kaffe mailing list