[kaffe] help

Dalibor Topic robilad at yahoo.com
Thu May 9 13:13:37 PDT 2002

Dear truename,

--- truename <ileftian at yeah.net> wrote:
> Dear Sir/Madam:  
>      I am interested in JanosVM Project. When I
> tried to install kaffe on my 
> computer, I encountered some problems that  I can't
> solve by myself.           
>      The details are as follows:
> System.c:In function
> 'java_lang_System_initProperties':
> System.c:415:warning:implicit declaration of
> function 'time'
> System.c:418:warning:implicit declaration of
> function 'localtime'
> System.c:418:invalid type argument of '->'
> gmake[3]:***[System.lo] Error 1
> gmake[3]:Leaving directory
> '/usr/local/kaffe-1.0.6/libraries/clib/native'
> gmake[2]:***[all-recursive] Error 1
> gmake[2]:Leaving directory
> '/usr/local/kaffe-1.0.6/libraries/clib'
> gmake[1]:***[all-recursive] Error 1
> gmake[1]:Leaving directory
> '/usr/local/kaffe-1.0.6/libraries'
> gmake:*** [all-recursive] Error 1

thanks you for your bug report. In order to be able to
help you solve the problems you have encountered with
kaffe, I need a few additional bits of information:

* did you try to compile kaffe or Janos VM? Your post
doesn't make that clear. If it was kaffe, which
version did you use, i.e. did you get the current
source from the CVS tree or did you use a release?

* As you have experienced a compilation problem, I
would like to know which platform you tried to compile
on. Kaffe runs on many platforms, from i386-linux to
sparc-solaris. Some bugs only show up on one platform.

* Finally, in order to be able to reproduce the bug, I
would like to know which commands you invoked to
configure and compile kaffe, as well as the compiler
version. Please post what you entered on the command
line, and the output of gcc -v.

best regards,

dalibor topic

Do You Yahoo!?
Yahoo! Shopping - Mother's Day is May 12th!

More information about the kaffe mailing list