[kaffe] Bug [CVS Version]: RMI/Object serialization

Hervé Roussain Herve.Roussain at univ-ubs.fr
Mon Apr 14 04:31:01 PDT 2003


There's a 'java.io.StreamCorruptedException: failed to read 
endblockdata' when I'm using RMI.

It seems that the bug comes from objects serialization. I've tried to 
replace Kaffe's RMI implementation with Classpath's one: there's no 
change (i.e. the bug remains the same).

I noticed that there's a comment in java.io.ObjectStreamClass with a big 
todo list...

So I've got a few questions:
1) Why did this class changed from version 1.11 (of the file) ?
2) Who remembered that this TODO list (and planned to work on it) ?
3) What version should be in Kaffe 1.1.0: the old version (1.11) which 
worked "not so bad", or a corrected version of the new one ?

The attached zipfile contains code from Sun's RMI tutorial (compiled 
with JDK 1.4) (if you want more info about the files, look at 

Here's the way to run the code:
(I know you know how to use RMI, but I just don't want you to lose time 
looking for the good classes to run...)
rmiregistry &
java engine.ComputeEngine (on a first term)
java client.ComputePi (on a second term)

I suggest you to try both Kaffe & Sun JDK for the server and the client...

-------------- next part --------------
A non-text attachment was scrubbed...
Name: RMI-computePi.zip
Type: application/x-zip-compressed
Size: 9235 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/20030414/ee38dcb3/attachment-0003.bin 

More information about the kaffe mailing list