[kaffe] Installing Kaffe on ia64

Adam Parrish waparris at ncsu.edu
Tue Dec 2 11:09:02 PST 2003

On Tue, 2003-12-02 at 11:49, Dalibor Topic wrote:
> Hi Adam,
> Adam Parrish wrote:
> > I downloaded and tried to build Kaffe for my first time today on an
> > IA-64 architecture. I am running Debian Linux 3 on 2.4.20 kernel. Has
> > anyone successfully compiled this software for ia64. I have read in
> > places that it is being ported, but I have not found any decent
> > documentation as to getting it to work. If anyone has any suggestion on
> > how to install the VM on my system I would definately appreciate it. 
> > 
> > The error I get is during the make for kaffe-1.0.7:
> Could you try again with kaffe 1.1.2? I believe that one should build 
> without problems on ia64-linux.

I gave 1.1.2 a shot and I am still getting errors. When I finished make
I ran make check and here is the output that mentioned errors.

Is there a fix for this?

Making check in compile_time
make[3]: Entering directory
lt-kaffe-bin: mem/gc-incremental.c:1019: gcMalloc: Assertion `fidx <
nrTypes && size != 0' failed.
make[3]: *** [DefinedToUndefined.class] Aborted
make[3]: Leaving directory
make[2]: *** [check-recursive] Error 1
make[2]: Leaving directory `/root/kaffe-1.1.2/test/regression'
make[1]: *** [check-recursive] Error 1
make[1]: Leaving directory `/root/kaffe-1.1.2/test'
make: *** [check-recursive] Error 1

> cheers,
> dalibor topic
Adam Parrish
Asst. Linux Administrator
ECE Dept, North Carolina State University
Office: 919.515.0124

More information about the kaffe mailing list