[kaffe] ANN: testing page and results

Dalibor Topic robilad at kaffe.org
Tue Dec 9 09:13:02 PST 2003

Ciao riccardo,

Riccardo wrote:
> Hello
> for Jim, Dalibor and others...
> failures on NetBSD, OpenBSD, Solaris... a big maze.

thanks for the great ressource of build failure logs!

> There is my current attempt to track down the sparc build problem on *
> BSD/sparc (besides, notice the current statups of OpenBSD: some stupid 
> header is acting up).
> Since Solaris did work in August I tried to update it gradually to see 
> if it breaks and if it breaks if it acts like BSD/sparc.

I've just tried to build 1.1.3 with sparc-solaris 2.9 with *interpreter* 
engine. That's usually the first thing I'd do when I try to isolate 
build errors on a platform. My configure line was:

cd build-intrp;
../kaffe-1.1.3/configure --prefix=/tmp/current-intrp --with-engine=intrp 
--enable-debug --enable-pure-java-math && make 2>faillog && make check 
&& make install

I'm getting one failed test, NetworkInterfaceTest.java.

:/tmp/topic/build-intrp [515] diff -u 
--- test/regression/NetworkInterfaceTest.fail   2003-12-09 
17:48:32.027949549 +0100
+++ test/regression/NetworkInterfaceTest.out    2003-12-09 
17:48:30.404478881 +0100
@@ -1,4 +1 @@
-kaffe.util.NotImplemented: OS doesn't support getifaddrs()
-   at java.net.NetworkInterface.getRealNetworkInterfaces 
-   at java.net.NetworkInterface.getNetworkInterfaces 
-   at NetworkInterfaceTest.main (NetworkInterfaceTest.java:23)

Riccardo, could you retry bulding kaffe on sparc-solaris 2.6 with the 
configure options above?

dalibor topic

More information about the kaffe mailing list