[kaffe] Assertion failed in CVS kaffe

Matthew Toseland toad at amphibian.dyndns.org
Sun Feb 23 07:04:01 PST 2003

I heard that freenet worked on kaffe CVS, so I tried it... I get
Error: Unrecognized JVM specific option

(this is presumably separate, I'll just take the option out)

kaffe-bin: jthread.c:1750: handleIO: Assertion `(__extension__
({register char __result; __asm__ __volatile__ ("btl %1,%2 
; setcb %b0" : "=q" (__result) : "r" (((int) (i)) % (8 * sizeof
(__fd_mask))), "m" (((&readsPending)->__fds_bits)[((i) / (
8 * sizeof (__fd_mask)))]) : "cc"); __result; }))' failed.

(this is one of the errors that kaffe used to crash out of freenet with).
It would be REALLY great if we could fix this. Is there any testing or
other help I can give you to try to fix this?

Matthew Toseland
toad at amphibian.dyndns.org/amphibian at users.sourceforge.net
Full time freenet hacker.
Freenet Distribution Node (temporary) at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/20030223/8f02c7a3/attachment-0003.pgp 

More information about the kaffe mailing list