[kaffe] Re: Re: OpenBSD compiles but fails

Dalibor Topic robilad at yahoo.com
Thu Jun 19 06:37:05 PDT 2003

ciao ricardo,

--- WhiteGandalf <zuse at libero.it> wrote:
> In <20030619085101.27856.qmail at web10006.mail.yahoo.com> Dalibor Topic  
> wrote:

> i reconfigured for the interpreter. I hope that make is smart enough to 
> rebuild what is necessary instead of cleaning and rebuilding everything (
> it takes some time on my aging sparc)

i don't know. if I were you, I'd start with a fresh build to avoid any stupid
mistakes from makefiles interfering with debugging. I'd build kaffe with
--enable-debug and --with-engine=intrp

> I did a further check:
> i have a simple Java file, i tried to first compile it:
> mallorn:multix {115} javac Loops.java
> Internal error: caught an unexpected exception.
> Please check your CLASSPATH and your installation.
> java/lang/NullPointerException
> Abort (core dumped)
> and it fails, giving the same error as trying to run the bytecode 
> compiled on another computer.
> So maybe there is really something stupid that broke? I have no 
> CLASSPATH set, what could I try to set? (I obviously only have kaffe 
> installed and not the official JDK which doesn't exist for OpenBSD)

time for everyfody's favorite passtime: debugging. Please read
FAQ/FAQ.debugging , run kaffe in gdb or ddd (the last one is a graphical gdb
frontend) and post the backtrace from the crash. I hope that will yield some
cles on what's going wrong.

dalibor topic

Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!

More information about the kaffe mailing list