[kaffe] Bug [CVS version]: Calling non-implemented method in abstract class

Timothy Stack stack at cs.utah.edu
Fri Mar 28 08:30:02 PST 2003

> Hi all,


> The following code:
> --- snip ---
> gives me the following error:
> benja at joy:~/ff/fenfire$ /usr/local/kaffe/bin/kaffe -cp build Bug
> java.lang.NoSuchMethodError: Bug$Abstract.foo()V
>          at Bug$Abstract.bug(source file unknown:line unknown, pc 0x81ff788)
>          at Bug.main(source file unknown:line unknown, pc 0x8220661)
> My Kaffe version (compiled from CVS, on Debian / x86):
>      Engine: Just-in-time v3   Version: 1.1.x-cvs   Java Version: 1.1
> Apparently, Kaffe doesn't like when an abstract class calls a method 
> from an interface the abstract class implements, if the abstract class 
> does not implement that method itself.

Yeah, I ran into this a little while ago and fixed it in the JanosVM.  Its 
actually because of a change in jikes, which is legal, but not handled 
correctly in Kaffe.  I'll see about porting over the JanosVM fix in a bit.

> Thanks,
> - Benja


tim stack

More information about the kaffe mailing list