[kaffe] /home/saif_rangwala/toolchains/arm/arm-linux/bin/ld: cannot find -ldl with kaffe-1.1.2

Saifuddin Rangwala saifuddingroups at yahoo.co.in
Fri Nov 14 00:16:01 PST 2003

I m getting the same error again.
So, is it a bug? or problem with my compiler,
I am using gcc-2.95.3 and uclibc-0.9.12 as cross
compiler for arm.

Also, I tried to disable sound with --disable-sound,
still it went to search Esd and configure failed.
That forced me to use --enable-pure-java-math.
I want to have minimal configuration like the one
which J2ME CDC provides, can I have that with
Ok thanks in advance,

//configure options
CC=arm-uclibc-gcc \
NM=arm-uclibc-nm \
AR=arm-uclibc-ar \
STRIP=arm-uclibc-strip \
RANLIB=arm-uclibc-ranlib \
AS=arm-uclibc-AS \
../kaffe/configure \
--prefix=/kaffe \
--host=arm-linux \
--build=i686-linux \
--with-rt-jar=$RT_JAR \
--with-staticvm \
--with-staticbin \
--with-static-lib \
--disable-debug \
--disable-xprofiling \
--disable-xdebugging \
--disable-feedback \
--without-profiling \
--without-stats \
--disable-gcj \
--disable-sound \
--without-esd \
--without-alsa \
--with-awt=no \
--with-libraries=$TOOLS/lib \
--with-include=$TOOLS/include \
 Also I am listing the configure option which I have
given. and the trace at the end of the mail. Please
check it.
arm-uclibc-gcc -g -O2 -Wall -Wstrict-prototypes
-fsigned-char -o kaffe-bin -static main.o version.o
.libs/kaffe-binS.o -Wl,--export-dynamic 
../kaffevm/.libs/libkaffevm.a -lm
../../libltdl/.libs/libltdlc.a -ldl -Wl,--rpath
cannot find -ldl
collect2: ld returned 1 exit status
rm -f .libs/kaffe-binS.o
make[2]: *** [kaffe-bin] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
make: *** [all-recursive] Error 1

Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://mail.messenger.yahoo.co.uk

More information about the kaffe mailing list