[kaffe] HP-UX and IPv6 still fail

Riccardo zuse at libero.it
Mon Sep 1 14:26:02 PDT 2003

HP-UX and IPv6 still fail

I tried compiling kaffe-cvs on another HP=UX 10.20 box, which has an 
older compiler (gcc 2.95) and generally less software installed, 
nevertheless inet6 functions fail to be correctly included from the 
dummy files probably.

./../../../kaffe/libraries/clib/net/InetAddressImpl.c: In function 
./../../../kaffe/libraries/clib/net/InetAddressImpl.c:489: `MAX_IPV6_
STRING_SIZE' undeclared (first use in this function)
./../../../kaffe/libraries/clib/net/InetAddressImpl.c:489: (Each 
undeclared identifier is reported only once
./../../../kaffe/libraries/clib/net/InetAddressImpl.c:489: for each 
function it appears in.)
./../../../kaffe/libraries/clib/net/InetAddressImpl.c:536: warning: 
implicit declaration of function `inet_ntop'
./../../../kaffe/libraries/clib/net/InetAddressImpl.c:489: warning: 
unused variable `ipaddr'
gmake[2]: *** [InetAddressImpl.lo] Error 1
gmake[2]: Leaving directory `/home/multix/kaffe-cvs/hpux-build/libraries/


More information about the kaffe mailing list