[kaffe] Re: Last Time Kaffe Worked on Darwin/OS X

Riccardo zuse at libero.it
Mon Apr 19 06:56:02 PDT 2004

In <FD94120A-91FF-11D8-BE19-000393AA19AE at verizon.net> Michael Franz  
> Hi,
> Does anyone know what was the last version of Kaffe that worked on 
> Darwin?  The README has reference to support on May 29, 2002.  I think 
> that it might be 1.0.7, but I am not sure.

I have no idea. It was always broken for me :)

I tested 1.0.7 right now on 10.2.8 and it fails
gcc -bundle -flat_namespace -undefined suppress -o .libs/libnative-1.0.7.
so  ByteToCharDefault.lo ByteToCharIconv.lo CharToByteDefault.lo 
CharToByteIconv.lo ObjectStreamClassImpl.lo Application.lo Class.lo 
ClassLoader.lo Compiler.lo Double.lo Float.lo Math.lo MemoryAdvice.lo 
NativeLibrary.lo Object.lo RMIHashes.lo Runtime.lo SecurityManager.lo 
String.lo System.lo SystemClassLoader.lo Thread.lo Throwable.lo 
UNIXProcess.lo ZipFile.lo Array.lo Constructor.lo Field.lo Method.lo 
DateFormat.lo TestNative.lo Arrays.lo  -lm -L/usr/local/lib -lc -install_
name  /usr/local/kaffe/jre/lib/powerpc/libnative-1.0.7.so 
gcc: -install_name only allowed with -dynamiclib
make[3]: *** [libnative.la] Error 1

maybe it works on 10.0 or 10.1 I have no idea. ATM it is unusable :)


More information about the kaffe mailing list