[kaffe] Solaris, 32 bit, fails (eowyn)

Riccardo zuse at libero.it
Sun Apr 25 06:03:02 PDT 2004


I build on "eowyn" (solaris, microsparcII, v8, 32bit) and it fails with 
an NPE. Could this still be a stack problem? (guilhem: were your patches 
for solaris checked in on Sunday morning?)

It behaves now exactly as shadowfax (Solaris, Ultrasparc, v9) behaves 
and NetBSD/sparc

CharToByteCP869.ser kaffe/io/CharToByteCP870.ser kaffe/io/
CharToByteCP871.ser kaffe/io/CharToByteCP875.ser kaffe/io/
CharToByteCP918.ser kaffe/io/CharToByteKOI8_R.ser
   at kaffe.tools.jar.Jar.updateFilesInJar (Jar.java:875)
   at kaffe.tools.jar.Jar.processJar (Jar.java:429)
   at kaffe.tools.jar.Jar.start (Jar.java:77)
   at kaffe.tools.jar.Jar.main (Jar.java:56)
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
	at java.lang.Runtime.runShutdownHooks(Runtime.java:230)
	at java.lang.Runtime.exitJavaCleanup(Runtime.java:95)
	at java.lang.System.exitJavaCleanup(System.java:138)
make[1]: *** [rt.jar] Abort (core dumped)

I wonder why Legolas (supersparc, v8, solaris) worked last time I tried. 
Guilhem made me change a line about stack limit, i didn't know if he 
commited a reliable thing for that.

One diffence that legolas doesn't have an L2 cache (I don't cknow 
exactly the caches of the others). The OS version is the same and the 
compier is the same. Maybe I really need to check out legolas too.


More information about the kaffe mailing list