[kaffe] error about -lqtopia

Dalibor Topic robilad at kaffe.org
Fri Aug 20 09:27:07 PDT 2004

王凯 wrote:
> I want to install kaffe on an xscale board.
> what I have done is:
> export CC=arm-linux-gcc
> export AS=arm-linux-as
> export LD=arm-linux-ld
> export CPP='arm-linux-gcc -E'
> export AR=arm-linux-ar
> export NM=arm-linux-nm
> export STRIP=arm-linux-strip
> export OBJCOPY=arm-linux-objcopy
> export OBJDUMP=arm-linux-objdump
> export RANLIB=arm-linux-ranlib
> export QTDIR=/usr/local/qt-2.3.2
> export QTEDIR=$QTDIR 
> export QPEDIR=/usr/local/qtopia-free-1.5.0
> export KAFFEH=/home/sitsang/tmp/sitsang_fs/usr/local/kaffe/bin/kaffeh
> export LD_LIBRARY_PATH=/usr/local/qt-2.3.2/lib:/usr/local/qtopia-free-1.5.0/lib:$LD_LIBRARY_PATH
> export PATH=$QTDIR/bin:$PATH
> export PATH=/home/sitsang/tmp/sitsang_fs/usr/local/kaffe/bin:$PATH
> export PATH=$QPEDIR/bin:$PATH 
> Then
> ./configure --prefix=/home/sitsang/tmp/sitsang_fs/usr/local/kaffe --build=i386-linux --host=arm-linux CC=arm-linux-gcc CXX=arm-linux-g++ CPP='arm-linux-gcc -E' --with-qtdir=/usr/local/qt-2.3.2 --with-awt=qt --with-includes=/usr/local/qtopia-free-1.5.0/include --with-libraries=/usr/local/qtopia-free-1.5.0/lib --without-x --target=arm-linux --enable-pure-java-math --disable-esdtest --without-esd --with-cpu=xscale
> The message showed to me is:
> arm-linux-g++ -shared -nostdlib /usr/local/arm-linux/arm-linux/lib/crti.o /usr/local/arm-linux/lib/gcc-lib/arm-linux/2.95.3/crtbeginS.o  .libs/tlk.o .libs/wnd.o .libs/evt.o .libs/gra.o .libs/fnt.o .libs/clr.o .libs/img.o .libs/cbd.o .libs/evt.moc.o  -Wl,--rpath -Wl,/usr/local/qtopia-free-1.5.0/lib -L/usr/local/qt-2.3.2/lib -lqpe -lqtopia -lqte-mt -L/usr/local/qtopia-free-1.5.0/lib -L/usr/local/arm-linux/lib/gcc-lib/arm-linux/2.95.3 -L/usr/local/arm-linux/arm-linux/lib -lstdc++ -lm -lc -lgcc /usr/local/arm-linux/lib/gcc-lib/arm-linux/2.95.3/crtendS.o /usr/local/arm-linux/arm-linux/lib/crtn.o  -Wl,-soname -Wl,libawt-1.1.4.so -Wl,-retain-symbols-file -Wl,.libs/libawt.exp -o .libs/libawt-1.1.4.so
> /usr/local/arm-linux/arm-linux/bin/ld: cannot find -lqtopia
> I find the makefile, and tried to add "-L/usr/local/qtopia-free-1.5.0" before -lqtopia, but not work.
> I also tried to delete "-lqtopia", then another error occurs:

Hmm, weird. Could you post your config.log, the Makefile in the
directory where the build fails, and your build log? I remember getting
qtopia and kaffe to work a while ago, but as I don't use it ...

> make[3]: Entering directory `/home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/test/regression/compile_time'
> /home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/kaffe/kaffe/kaffe-bin: line 105: /home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/kaffe/kaffe/.libs/lt-kaffe-bin: cannot execute binary file
> /home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/kaffe/kaffe/kaffe-bin: line 105: /home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/kaffe/kaffe/.libs/lt-kaffe-bin: pass
> make[3]: *** [ClassToInterface.class] Error 1
> make[3]: Leaving directory `/home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/test/regression/compile_time'
> make[2]: *** [all-recursive] Error 1
> make[2]: Leaving directory `/home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/test/regression'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/sitsang/tmp/sitsang_fs/home/wangkai/kaffe-1.1.4/test'
> make: *** [all-recursive] Error 1
> Since I use arm-linux-gcc to compile kaffe, the final executable file certainly cannot be executed in PC linux.
> But I still wonder if these files is the ones I want.
> And this step of make looks like a porcess of checking, maybe the error comes from the unexecutable file. If so, how can I stop the check process?

Yes, that was a bug in 1.1.4. Fixed in CVS. Use make -k to make sure
that make ignores the failure.

dalibor topic

More information about the kaffe mailing list