[kaffe] What a true CLASSPATH should be?

王凯 wang__kai__ at hotmail.com
Mon Aug 30 00:55:24 PDT 2004

I want to install kaffe in my arm linux, and compile it in my i386 linux.
I compliled the kaffe like this:

export CC=arm-linux-gcc
export AS=arm-linux-as
export LD=arm-linux-ld
export CPP='arm-linux-gcc -E'
export AR=arm-linux-ar
export NM=arm-linux-nm
export STRIP=arm-linux-strip
export OBJCOPY=arm-linux-objcopy
export OBJDUMP=arm-linux-objdump
export RANLIB=arm-linux-ranlib
export QTDIR=/usr/local/qt-2.3.2
export QPEDIR=/usr/local/qtopia-free-1.5.0
export KAFFEH=/usr/local/kaffe/bin/kaffeh
export LD_LIBRARY_PATH=/usr/local/qt-2.3.2/lib:/usr/local/qtopia-free-1.5.0/lib:$LD_LIBRARY_PATH
export PATH=$QTDIR/bin:$PATH
export PATH=/usr/local/kaffe/bin:$PATH
export PATH=$QPEDIR/bin:$PATH 

./configure --prefix=/usr/local/kaffe --build=i386-linux --host=arm-linux CC=arm-linux-gcc CXX=arm-linux-g++ CPP='arm-linux-gcc -E' --with-qtdir=/usr/local/qt-2.3.2 --with-awt=qt --with-includes=/usr/local/qtopia-free-1.5.0/include --with-libraries=/usr/local/qtopia-free-1.5.0/lib --without-x --target=arm-linux --enable-pure-java-math --disable-esdtest --without-esd --with-cpu=xscale

Then an error about "-lqtopia" occured. I deleted the "-lqtopia" in the makefile. After that, a new problem about "can not execute" occured in the process of make. Since someone told me that it is a bug of kaffe-1.1.4, I use make -t to ignore all the errors left.

Then I got the final files. I put them into the folders respectively according to the kaffe installed in my i386 linux.

When I tried to use it in the arm linux, a new problem comes:

[root at Linux 1]$appletviewer HelloWorld.html
pc : [<401f8ab8>]    lr : [<401f89d4>]    Not tainted
sp : bffff7c0  ip : bffff7d0  fp : bffff7cc
r10: 400d5e84  r9 : 40066050  r8 : 400ec2a4
r7 : 002210d4  r6 : 002210d4  r5 : 00000000  r4 : 00000080
r3 : 00000000  r2 : 00000020  r1 : 00000000  r0 : 002210d0
Flags: Nzcv  IRQs on  FIQs on  Mode USER_32  Segment user
Control: 397F  Table: A323C000  DAC: 00000015
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.

I have tried to set the CLASSPATH like this:
export CLASSPATH="./:/usr/local/kaffe/lib:/usr/local/kaffe/jre/lib"

But it doesn't work.

Is it really something wrong about CLASSPATH? If so, what a true CLASSPATH should be?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://kaffe.org/pipermail/kaffe/attachments/20040830/912cd2fd/attachment-0006.htm 

More information about the kaffe mailing list