[kaffe] Trouble running Eclipse 3.0.1 with recent Kaffe snapshot

Dalibor Topic robilad at kaffe.org
Fri Dec 17 12:05:32 PST 2004

Haakon Nilsen wrote:
> Hi,
> I was adviced on IRC to send this to the list.
> I have been trying to run Eclipse binaries for Linux/GTK on Kaffe. First I
> tried on the standard 1.1.4 release, which immediately resulted in some
> NullPointerExceptions. I then tried compiled a CVS snapshot from Dec 15,
> which I got from the source package of the latest Kaffe on Debian Unstable.
> Running on this, it still fails at the same point, but with a different
> error related to parts of java.nio not being implemented. The complete log
> follows. I hope this is something that can be solved without substantial
> effort!
Hi Haakon,

thanks for your bug report. In order to get Eclipse3 to run, you need 
the CVS head and to run it with the following line (for 3.1.0):

/path-to/bin/kaffe -mx 128M 
-Dosgi.locking=none -cp startup.jar org.eclipse.core.launcher.Main -os 
linux -ws gtk -consolelog

the osgi.locking property is very important, as you've found out ;)

dalibor topic

More information about the kaffe mailing list