[kaffe] why kaffe and tomcat on sh3 are not ready?

周光华 g_zhou at hitachi.com.cn
Mon Feb 9 17:27:02 PST 2004

Dear all,
    I am struggling to port kaffe and Tomcat to SolutionEngine7709A (sh3). It's OS is SH-Linux (2.4.18).
    Firstly, I tried to compile kaffe-1.1.3.tar.gz on SolutionEngine7709A:
bash-2.05a#./configure --with-engine=intrp --host=superh-linux
bash-2.05a# make
Making all in .
make[1]: Entering directory `/home/kaffe/kaffe-1.1.3'
Making all in compile_time
make[3]: Entering directory `/home/kaffe/kaffe-1.1.3/test/regression/compile_time'
java.lang.ClassNotFoundException: at.dms.kjc.Main
   at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:296)
   at java.lang.ClassLoader.loadClass (ClassLoader.java:142)
java.lang.ClassNotFoundException: at.dms.kjc.Main
   at kaffe.lang.AppClassLoader.findClass (AppClassLoader.java:296)
   at java.lang.ClassLoader.loadClass (ClassLoader.java:142)

    So I gave up kaffe-1.1.3.tar.gz .

    Then I compiled kaffe-1.0.7.tar.gz on SolutionEngine7709A. I copied the directory of superh in kaffe-1.1.3.tar.gz to  kaffe-1.0.7/config, and add one line to kaffe-1.0.7/config/md.h: #include "superh/linux/md.h", and changed known=no to known=yes in the file of kaffe-1.0.7/configure. Then I run 
make install 
All commands run OK, then I tested HelloWorld.java
bash-2.05a# javac HelloWorld.java
bash-2.05a# ls
HelloWorld.class  HelloWorld.java
bash-2.05a# java HelloWorld
Hello World, my dear
But it fails:
bash-2.05a# java HelloWorld.class
java.lang.ClassNotFoundException: HelloWorld/class
        at java.lang.Class.forName(Class.java:native)
        at java.lang.Class.forName(Class.java:58)
The /etc/profile is set with:
JAVA_OPTS="-ss96k -mx256M -Dbuild.compiler=kjc"

Then I test tomcat 4.1.29, it fails:
bash-2.05a# catalina.sh  run
Using CATALINA_BASE:   /usr/local/jakarta-tomcat-4.1.29
Using CATALINA_HOME:   /usr/local/jakarta-tomcat-4.1.29
Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.1.29/temp
Using JAVA_HOME:       /usr/local/kaffe
Couldn't find or load essential class `java/lang/Object' java.lang.NoClassDefFou
ndError java/lang/Object

Thanks very much!
                                                                                                                                                                                                   zhou guanghua 

More information about the kaffe mailing list