[kaffe] Does not work on FreeBSD 5.1-RELEASE

Guilhem Lavaux guilhem at kaffe.org
Wed Jul 14 11:56:45 PDT 2004

Ito Kazumitsu wrote:

>>>>>>"*" == Guilhem Lavaux <guilhem at kaffe.org> writes:
>*> Hmm... I've just tried running kaffe on freebsd 5.1 on my laptop and it 
>*> manages to run kjc to build the class library so I guess it works.
>Yes, it worked for me, too, after changing the configuration
>option --with-threads from unix-pthreads to unix-jthreads.
>Well, an older version whose ChangeLog head is
>   2004-06-22  Kiyo Inaba <inaba at src.ricoh.co.jp>
>configured --with-threads=unix-pthreads works fine
>on FreeBSD 4.7-RELEASE.  So I would like to try to use
>--with-threads=unix-pthreads on FreeBSD 5.1-RELEASE, too.

Hi Ito,

This is fixed in the CVS HEAD now. I had removed a jmutex_lock 
incidentally when fixing solaris. It is working here now with pthreads. 
Could you test it ?

BTW, Riccardo could you try again solaris with that fix ?



More information about the kaffe mailing list