[kaffe] StrongARM problems

Jari Korva jpkorva at iki.fi
Wed Jun 9 04:13:02 PDT 2004


I've been trying to compile Kaffe for iPAQ 3660 (StrongARM 1100). So far,
I've had only limited success:

By default, libraries/javalib/rebuildLib in 1.1.5branch tries to use
cross-compiled kaffe for building Java libraries. I added JAVA=<path
to native kaffe> into the script which fixed the problem. Another problem
I run into during the build process was that 1.1.4 didn't work as native
compiler - I had to upgrade it to 1.1.5branch too. After these
modifications the compile progressed "far enough" (i.e. it failed while
trying to build regression tests), but trying to run kaffe fails:

# kaffe HelloWorld

I also tried to compile cvs head, but it failed at:

In file included from ../../../config/arm/linux/md.h:16,
                 from ../../../config/md.h:1,
                 from Class.c:18:
../../../config/arm/sysdepCallMethod.h:32:5: warning:
"NEED_sysdepCallMethod" is not defined
In file included from ../../../config/arm/linux/md.h:48,
                 from ../../../config/md.h:1,
                 from Class.c:18:
../../../config/arm/linux/sigcontextinfo.h:20:28: bits/armsigctx.h: No
such file or directory
../../../config/arm/linux/sigcontextinfo.h:21:29: kernel-features.h: No
such file or directory

I used following configuration:

./configure --prefix=/wrk/ipaq/u/jko/test --build=i386-linux
--host=arm-unknown-linux-gnu --without-x --disable-alsatest
--disable-esdtest --disable-sound --enable-pure-java-math
--with-threads=unix-pthreads --with-engine=jit

...and cross compiler:

arm-unknown-linux-gnu-gcc -v
Reading specs from
Configured with:
--target=arm-unknown-linux-gnu --host=i686-host_pc-linux-gnu
--disable-nls --enable-threads=posix --enable-symvers=gnu
--enable-__cxa_atexit --enable-languages=c,c++,java --enable-shared
--enable-c99 --enable-long-long
Thread model: posix
gcc version 3.3.1

Is there any solution to these problems or should I try some older


 - Jari Korva -

More information about the kaffe mailing list