[kaffe] JVMPI status?

Dalibor Topic robilad at kaffe.org
Fri Mar 12 10:54:18 PST 2004

Hi Jon,

Jon Nall wrote:
> dalibor,
> i don't think this is a libtool bug. i think the solution is to remove 
> it from libltdl/acinclude.m4:6372. i don't have up to date 
> autoconf/automake, so i can't test it, but manually removing it from 
> libltdl/configure:21057 worked.

the libltdl directory comes from GNU libtool: it is created by running 
libtoolize from libtool 1.5.2. I'll forward your bug report and fix to 
the libtool developers, it's a very good catch.

> i'm attaching a patch that should resolve both the malloc issue and the 
> assert i mentioned in my previous email.

thanks, I've checked it in. I've adapted the libtool patch slightly to 
fit into our build system.

> current status is that i can get EJP to load and run successfully on 
> small programs. i tried it on a larger program and got an internal error 
> in EJP (an error that doesn't show up when i run against the sun JDK). 
> so i'll debug that one next.

thanks for doing that!

dalibor topic

More information about the kaffe mailing list