[kaffe] (no subject)

Dalibor Topic robilad at kaffe.org
Mon Mar 15 12:30:02 PST 2004

Hi Heppan,

heppan at arcor.de wrote:
> today i have a two problems...
> 1. the first problem i have is that i can't run make successfully when i want to crosscompile kaffe 1.1.3 for an arm. 
> my configure: ./configure --prefix=/home/pr4/local/kaffe113arm --host=arm-linux --build=i686-linux --enable-pure-java-math
> --enable-pure-java-math is needed, because without i got the error message Information: Enlightened Sound Daemon not found
> configure: error: Could not find GNU MP library.  Install the gmp development package, or pass --enable-pure-java-math to configure.
> but GNU MP (version 4.1.2-94) is installed. anyway, when i run make after successfull configure make aborts with: 
> Relocations in generic ELF (EM: 3)
> .libs/ByteToCharDefault.o: could not read symbols: File in wrong format
> collect2: ld returned 1 exit status
> make[2]: *** [libnative.la] Fehler 1
> by the way, i got the same with kaffe 1.1.4, pherhaps it'S no problem with kaffe, does someone know a solve? i couldn't solve this problem yet, so i want to compile kaffe direct at the device, and there is the next problem

Take a look at FAQ/FAQ.cross-compiling. I assume that the problem is 
that you didn't explicitely set the linker to the arm linker.

> 2. i had compiled java on a SimPad (no crosscompiling, OS is Debian and CPU is an ARM). when i want to start a small java programm always it aborts with the message: 
> kaffe-bin: exception.h:139: vmExcept_setJNIFrame: Assertion `fp != 0' failed.
> Aborted
> i tried to find exception.h to take a look on it, but i couldn't find the file...

You should try out the CVS, it has had a few improvements for ARM 
architecture. If your platform is an xscale/pxa, you need to 
--enable-pxa in configure.

dalibor topic

More information about the kaffe mailing list