[kaffe] StrongArm broken as well

Kero van Gelder kero at chello.nl
Sat May 1 08:53:10 PDT 2004

> while Solaris/sparc seems to get a temporary comeback and compile... 
> NetBSD/sparc is still broken
> /bin/sh ./rebuildLib @essential.files
> Compiling classes from  @essential.files  using  /home/multix/kaffe-cvs/
> netbsd-sparc/kaffe/kaffe/kaffe-bin -verbosegc -mx 256M at.dms.kjc.Main
> Illegal instruction - core dumped

I don't even have to copy the message from the ipaq; it is the same.

For crosscompiling, I used jikes, so the Illegal Instruction came when
I tried to run kaffe on the ipaq.

We're talking cvs, gcc native:2.95.4 / cross:3.3.2, jit, pthreads
(intrp and/or jthreads have never worked, iirc).

Lacking space on my own iPAQ and up-to-date tools on the remote ipaqs,
I can not give more info than this. gdbserver isn't very helpful,
either (but that may be my inexperience with it).

I get tons of warnings, both when compiling and cross-compiling (200
resp 150 kByte of applicable text in stderr), many of which are about
different types (some due to missing prototypes) and signed/unsigned
issues (may be default char type, can have weird effects). Then a
bunch of Code Unreachable, (irrelevant).

This isn't much help to you, but it should be known before 1.1.5 is


+--- Kero ----------------------- kero at chello@nl ---+
|  all the meaningless and empty words I spoke      |
|                      Promises -- The Cranberries  |
+--- M38c --- http://httpd.chello.nl/k.vangelder ---+

More information about the kaffe mailing list