[kaffe] need detailed steps to configure kaffe 1.1.4 --with-awt=qt for pxa255

谢文学 xie248 at mail.biti.edu.cn
Sat May 29 18:54:02 PDT 2004

[it's very long,but i just want to ask questions more detaied,thanks for reading
   i have been working on porting kaffe 1.1.4 to an xscale pxa255 linux board for
one month.first i tried to use --with-awt=X,the cross compile process really
produced out an 
ARM version of kaffe,and with libawt.so(somthing like that).but at last i give up 
,because i 
foud that my target board doesn't surport Xlibs. then i turned to use
unfortunately,i haven't get the cross process going well. 
   here is it,hope someone be kind enough to help me out,thanks! 

step 1:

i downloaded qt-embedded-free-3.1.1 and use

 export QTDIR=/root/qt-embedded-free-3.1.1/
 export LD_LIBRARY_PATH=/root/qt-embedded-free-3.1.1/lib/
 ./configure -embedded arm -static -release

 during the building process,it turned out a warning to say:

WARNING: Failure to find: .moc/debug-shared-emb-arm/allmoc.cpp

anyway ,the process went on and produed libqte.so.3.1.1 in

and i checked ibqte.so.3.1.1 use
file ibqte.so.3.1.1 ,and found it's really for ARM.

step 2:

when enter into kaffe-1.1.4,use

 CFLAGS="-D__XSCALE__" NM=arm-linux-nm AR=arm-linux-ar CC=arm-linux-gcc
./configure --with-awt=qt --disable-debug  --enable-pxa --host=arm-linux 
--enable-pure-java-math KAFFEH=/usr/local/kaffe/bin/kaffeh
--with-rt-jar=/usr/local/kaffe/jre/lib/rt.jar --with-threads=unix-jthreads
--prefix=/usr/local/java --with-staticlib --with-staticvm --with-staticbin

see,the options i used are too long,they are collected from the mailing archeve
.but  it still can't work .when i use make,error turned on.

Making all in config
make[1]: Entering directory `/root/jvm/kaffe-1.1.4/config'
make  all-am
make[2]: Entering directory `/root/jvm/kaffe-1.1.4/config'
/bin/sh ../config/regen-forward ./arm/linux/md.h md.h stamp-h02
/bin/sh ../config/regen-forward ../config/arm/callKaffeException.h
callKaffeException.h stamp-h04
make[2]: Leaving directory `/root/jvm/kaffe-1.1.4/config'
make[1]: Leaving directory `/root/jvm/kaffe-1.1.4/config'
Making all in include
make[1]: Entering directory `/root/jvm/kaffe-1.1.4/include'
/usr/local/kaffe/bin/kaffeh -classpath ../libraries/javalib/Klasses.jar.bootstrap
-o java_lang_Object.h java/lang/Object
/usr/local/kaffe/bin/kaffeh: error while loading shared libraries:
/root/qt-embedded-free-3.1.1/lib/libqte.so.3: ELF file OS ABI invalid
make[1]: *** [stamp-h0all] Error 127
make[1]: Leaving directory `/root/jvm/kaffe-1.1.4/include'
make: *** [all-recursive] Error 1

I am really drunken  mad for that,because i have tried many many times,with
different options,and i really need
it. i saw some body see CVS kaffe is better now ,but unfortunately,i can't access
to CVS kaffe[sorry i don't know how to access,i tried cvs -d
:pserver:readonly at cvs.kaffe.org:/cvs/kaffe login ,but always timeout.and i can't
download anything from ViewCVS / CVSWeb---you see now ,i am a really newbie to
linux world,about 2 months.]

BTW: i have tried blackdown java 1.3.1 armv4l ,but still can't have awt ,because i
don't known how to get X server run on that board,and how to make connect to X

Can anyone give me any help?any suggestions will be apprreciated.Thanks!

still BTW:my arm-linux-gcc is v3.2.1(some body say 3.2.x isn't good for my
case,but i don't know how to update it anyway. ). and now my target already have
qpe libraries in it.

Help badly needed!


More information about the kaffe mailing list