[kaffe] Re: darwin6 pthread still broken

Guilhem Lavaux guilhem at kaffe.org
Tue Oct 12 09:28:59 PDT 2004

Riccardo wrote:
> Hmm..
> I tried reverting the two lines in gc-mem.c fro Noa as he suggested some 
> days ago and I still have the same error...
> bad bad, pthread is definively broken.
> -R

Hi Riccardo,

Yes, I know. It is due to thread life cycle in kaffe. I was on the edge 
of fixing it (well I think ... ;) ) when I run out of time some day ago.
It is fully reproducible on x86/linux too. But you have to charge 
heavily the system (with a qemu for example) to push the system 
executing the threads in different orders.


Guilhem Lavaux.

> In <20041011230611282+0200 at news.gmane.org> Riccardo  wrote:
>>As the title says:
>>Compiling classes from  @all.files  using  /Users/multix/kaffe-cvs/
>>darwin-intrp/kaffe/kaffe/kaffe-bin -verbosegc -ss 500k -mx 512M at.dms.
>>[ start compilation in verbose mode ]
>>[ parsed com/jcraft/jzlib/Adler32.java in 2,136 ms ]
>>h: 246: failed assertion `tid->suspendState == SS_SUSPENDED' /
>>rebuildLib: line 60: 13271 Abort trap              $JAVAC $VERBOSE 
>>$JAVAC_FLAGS -d $LIBDIR $CPATH ${1+"$@"} make[3]: *** [lib/stamp] 
>>Error 134
> _______________________________________________
> kaffe mailing list
> kaffe at kaffe.org
> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list