[kaffe] reproducible lockup with jit3 in System.runFinalization()

Noa Resare noa at resare.com
Tue Sep 14 14:40:54 PDT 2004

continuing with the detective work to get mauve to work with cvs kaffe
on my box i found a lockup in System.runFinalization(). When I run the
attached code the kaffe-bin process hangs with 100% CPU usage. When
attaching to the process with strace i get this:

futex(0x99f8050, FUTEX_WAIT, 1, NULL <unfinished ...>

This is reproducible with cvs kaffe as of today, with jit3 engine (intrp
and jit doesn't lock up) on i386 Fedora Core 2 and FC3beta1.
Have tried with jikes, kjc and sun's javac 1.4.2_05, all with the same

Does anyone else see this? How does one go about debugging this further?


ps. A bugzilla or similar for kaffe would be nice to have. Are there any
plans for that?

And the lions ate the christians and the christians burned the witches,
and even I am out of explanations -- Ola Salo
gpg fingerprint: F3C4 AC90 B885 FE15 344B  4D05 220B 7662 A190 6F09
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Locker.java
Type: text/x-java
Size: 1478 bytes
Desc: not available
Url : http://kaffe.org/pipermail/kaffe/attachments/20040914/9c2f947f/attachment-0002.java 

More information about the kaffe mailing list