[kaffe] even stranger problems on darwin5

Riccardo zuse at libero.it
Thu Sep 16 14:02:39 PDT 2004


investigating the trouble on darwin5 (discussed privately with dalibor, 
sorry), I tried to configure and build with a pre-supplied rt.jar. he 
build still fails, this way:

CLASSPATH=../../../../kaffe/libraries/javalib/rt.jar BOOTCLASSPATH=../../../../
kaffe/libraries/javalib/Klasses.jar.bootstrap /bin/sh ../../../libraries/
javalib/rebuildLib java/math/BigDecimal.java java/math/BigInteger.java
Compiling classes from  java/math/BigDecimal.java java/math/BigInteger.
java  using  /Users/multix/kaffe-cvs/darwin5/kaffe/kaffe/kaffe-bin -
verbosegc -ss 500k -mx 512M at.dms.kjc.Main
[ start compilation in verbose mode ]
error:I/O Exception on file "/Users/multix/kaffe-cvs/darwin5/libraries/
javalib/gmp-math/lib": /Users/multix/kaffe-cvs/darwin5/libraries/javalib/
gmp-math/lib is a directory
[ parsed java/math/BigDecimal.java in 9,406 ms ]
[ parsed java/math/BigInteger.java in 16,505 ms ]
make[3]: *** [lib/stamp] Error 1

The error is still the same... Also I don't see why those classes should 
be built.


More information about the kaffe mailing list