[kaffe] Re: m68k-ecos

Kiyo Inaba inaba at src.ricoh.co.jp
Wed Dec 28 03:15:08 PST 2005

For several months, I only had one m68k machine working, and I tested
kaffe with m68k/netbsd. But recently, I reinstalled one more with second
hand logic board purchased.

On this 'new' machine (IIci), I setup regression test for m68k/linux
again, and later I build latest with compiling option.

Kiyo Inaba wrote:
>Dalibor wrote:
>>In particular since you are compiling kaffe for m68k-ecos, I'd suggest
>>turning gcc's optimisation off (CFLAGS=-O0), as people have reported
>>various problems with m68k and older gcc version being overeager on
>>optimisation. I've CC:ed Kiyo, who I recall having worked around some
>>m68k gcc problems in the past, he may have additional sugegstions as well.
>It is always very good custom to disable optimization for testing.
>Currently, I put optimization to be -O1 for both m68k-linux or m68k-netbsd
>in config.frag, and the tester can modify this line to be set to -O0 for
>his sake.
>As far as optimization (of m68k) is concerned, of course you can select
>-O0, -O1 or even -O2 and current snap MAY work for all of these settings
>(for linux or netbsd), and the reason why I put -O1 in spite of -O2 is
>-O1 makes firster executables than -O2 (if I remember correctly). As
>Dalibor mentioned, I found some bugs of optimization but it only happens
>for jit (or jit3) and if you use intrp engine, this should be OK. I
>fixed the bug by putting proper register prologue in sysdepCallMethod
>and now it works.

These description is not true for m68k/linux, the regression fails
with -O0! The sysdepCallMethod written in C (for linux) should introduce
this problem. It is ok with -O1, and both -O0 and -O1 are ok for m68k/netbsd.

I found 'Coldfire emulator' at http://www.slicer.ca/coldfire, and it
can be a good start to play with coldfire port. I will do this some
time next year.

P.S. I found what I have in my home is not Coldfire, but Dragonball.

More information about the kaffe mailing list