[kaffe] Porting KAFFE on XScale PXA250

schlank schlank at 126.com
Tue Jan 25 08:51:28 PST 2005

Hi all,

Has anyone ever tried to port KAFFE 1.1.4 on an Intel XScale PXA250 

I compiled the kaffe-1.1.4 by the following steps:

export PATH=/opt/develop-tools-dist/bin:$PATH 
export AS=arm-linux-as
export LD=arm-linux-ld
export CPP='arm-linux-gcc -E'
export AR=arm-linux-ar
export NM=arm-linux-nm
export STRIP=arm-linux-strip
export OBJCOPY=arm-linux-objcopy
export OBJDUMP=arm-linux-objdump
export RANLIB=arm-linux-ranlib
export KAFFEH=/usr/local/kaffe/bin/kaffeh

./configure --host=arm-linux --build=i686-linux \
     CC=arm-linux-gcc NM=arm-linux-nm AR=arm-linux-ar    \
     CXX=arm-linux-g++ CPP='arm-linux-gcc -E'    \
     --enable-pure-java-math --without-x \
     --disable-sound --disable-alsatest --disable-esdtest    \
     --prefix=/kaffe --without-alsa --without-esd    \
     --with-cpu=xscale --with-rt-jar=/tmp/rt.jar \
     --with-staticlib --with-staticvm --with-staticbin   \

and then:
make -k
make install.

When I run a simple java app on the pxa250,

I get the error:

/kaffe/jre/bin # ./kaffe-bin TKA
pc : [<00034c4c>]    lr : [<0000ccb8>]    Not tainted
sp : bfffebd0  ip : bfffec88  fp : 00000000
r10: 002cacac  r9 : bfffee0c  r8 : 002cfa3c
r7 : 0024c838  r6 : 00000000  r5 : 00000000  r4 : 00000000
r3 : 00000000  r2 : 00000000  r1 : 00000080  r0 : 00000000
Flags: nZCv  IRQs on  FIQs on  Mode USER_32  Segment user
Control: 397F  Table: A3FE8000  DAC: 00000015
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.
/kaffe/jre/bin # sh: turning off NDELAY mode

Has anyone got the same problem? How can it be solved? Is there a patch
or something else to apply?

Thanks in advance.

More information about the kaffe mailing list