[kaffe] Getting 1.1.5 running on OpenBSD 3.7

Kurt Miller truk at optonline.net
Tue Jul 19 09:51:18 PDT 2005

From: "Vacuum Joe" <vacuumjoe at yahoo.com>
>> Tomcat 5.0 is in ports. Tomcat 5.5 isn't yet for no
>> other
>> reason then me slacking. Tomcat 5.5 doesn't strickly
>> require 1.5. It can be run using 1.4 if you use the
>> compatiblilty libs provided.
> Yes, I saw them in the ports.  They want Sun JDK 1.4. 
> I'm sure I could get that going, but I want to get
> this going with Kaffe instead.  I would rather have a
> fully open-source system that I can work on.  Any tips
> for this?  I'm pretty sure that it is possible to run
> Tomcat on Kaffe.  Right now, Tomcat 5.5 exits saying
> it requires a 1.5 JVM.  Kaffe reports as being Java
> 1.1, even though it is capable of running a lot of 1.5
> classes.  Tomcat 5.0 exits saying it needs JDK instead
> of a JRE.  Again, Kaffe has kjc so it should be able
> to do everything Tomcat 5.0 needs (ie, compile JSPs).
> Any ideas?

Hack the startup scripts to not do those checks or
make them work for kaffe?


More information about the kaffe mailing list