[kaffe] CLASSPATH init with Kaffe 1.1.5

Stage Iup - Fabrice & Frédéric stageiup at gmail.com
Tue Jun 7 01:07:17 PDT 2005

hi all
yesterday i've got a problem with kaffe 1.0.7
so as you said me, i've tried to use the 1.1.5 version downloaded form the 

i've succed in building it with the following command line
KAFFEH=/usr/local/kaffe/bin/kaffeh CC=/usr/local/arm/3.0/bin/arm-linux-gcc 
AR=/usr/local/arm/3.0/bin/arm-linux-ar ./configure --host=arm-linux 
--build=i386-linux --with-rt-jar=/home/stage/dev/kaffe/kaffe-1.1.5/tmp/rt.jar 
--enable-pure-java-math --without-classpath-gtk-awt 
--with-threads=unix-jthreads --without-x
1.1.5 --disable-debug --with-engine=intrp --disable-esdtest --disable-sound 

but when i try to use the VM, it doesn't work

i've launche the -version option to test if the building was well done
[root at EmbeddedLinux bin]$java -version
Kaffe Virtual Machine

Copyright (c) 1996-2004 Kaffe.org <http://Kaffe.org> project contributors 
(please see
the source code for a full list of contributors). All rights reserved.
Portions Copyright (c) 1996-2002 Transvirtual Technologies, Inc.

The Kaffe virtual machine is free software, licensed under the terms of
the GNU General Public License. Kaffe.org <http://Kaffe.org> is a an 
independent, free software
community project, not directly affiliated with Transvirtual Technologies,
Inc. Kaffe is a Trademark of Transvirtual Technologies, Inc. Kaffe comes

Engine: Interpreter Version: 1.1.5 Java Version: 1.1

and next, i've tried my helloWorld but having the classpath error
[root at EmbeddedLinux bin]$java /root/helloworld
pc : [<4006236c>] lr : [<40062340>] Not tainted
sp : bffff984 ip : 40247bdc fp : bffff9ac
r10: 40079aac r9 : 000136d8 r8 : 00013670
r7 : 000136d8 r6 : 00000005 r5 : 4007fde4 r4 : 00001000
r3 : c0000000 r2 : bffff000 r1 : 4007fde4 r0 : 00001000
Flags: nzCv IRQs on FIQs on Mode USER_32 Segment user
Control: C000317F Table: 21F3C000 DAC: 00000015
pc : [<401f1924>] lr : [<401f1848>] Not tainted
sp : bffff928 ip : 40079ff4 fp : bffff968
r10: 40079aac r9 : 4004f01c r8 : 00000001
r7 : 002630d8 r6 : 00000080 r5 : 00000000 r4 : 002630d8
r3 : 00000000 r2 : 00000020 r1 : 00000000 r0 : 002630d8
Flags: Nzcv IRQs on FIQs on Mode USER_32 Segment user
Control: C000317F Table: 21F3C000 DAC: 00000015
Internal error: caught an unexpected exception.
Please check your CLASSPATH and your installation.

does anyone have an idea about it?

with regards

Plateforme Technologique Valence
Tél : 04 75 41 88 58
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://kaffe.org/pipermail/kaffe/attachments/20050607/fa0c6df3/attachment-0005.htm 

More information about the kaffe mailing list