[kaffe] Bug report: Assertion failure when running Sun's DialogDemo

Niels Möller nisse at lysator.liu.se
Wed Nov 16 09:09:04 PST 2005

I have installed kaffe-1.1.6, using ./configure && make and no special
options. Then I tried running the Dialogs demo, consisting of the
files DialogDemo.java, CustomDialog.java and middle.gif, available at

I put all three files in a directory of their own, ran

  $ javac DialogDemo.java CustomDialog.java

to compile them, and then I tried to run the program,

  $ kaffe DialogDemo
  kaffe-bin: machine.c:256: translate: Assertion `reinvoke == false' failed.
  Aborted (core dumped)

Top of the gdb backtrace looks like

  (gdb) bt
  #0  0xb7d9283b in raise () from /lib/tls/libc.so.6
  #1  0xb7d93fa2 in abort () from /lib/tls/libc.so.6
  #2  0xb7d8c2df in __assert_fail () from /lib/tls/libc.so.6
  #3  0xb7f3564c in translate (xmeth=0x818b84c, einfo=0xb6c28708)
      at machine.c:387
  #4  0xb7f44022 in soft_fixup_trampoline (_data=0x0) at methodcalls.c:54
  #5  0xb7f442ae in i386_do_fixup_trampoline ()
      at ../../../config/i386/trampolines.S:50
  #6  0x0818d851 in ?? ()
  #7  0xb7f4429e in i386_do_fixup_trampoline ()
      at ../../../config/i386/trampolines.S:44
  #8  0x084b8cac in ?? ()
  #9  0xb6c28778 in ?? ()

I'm running on an x86 debian gnu/linux box,

  $ uname -a
  Linux carduelis.s3.kth.se #1 Thu Aug 18 11:42:45 CEST 2005
  i686 GNU/Linux

I used gcc-3.3.5 for the compilation.

(I also have the debian package of kaffe-1.1.5 installed, and it can
run the dialogs demo. However, the
javax.swing.JOptionPane.showInputDialog seems broken, it doesn't
create any text input field. The reason I upgraded to kaffe-1.1.6 was
to see if this problem has been fixed).


More information about the kaffe mailing list