[kaffe] Can't find or load essential class on ARM target

Rabeeh Khoury rabeeh at marvell.com
Mon Nov 28 14:00:17 PST 2005

Hi All,

This is first time I use Kaffe; so the following is a long newbie

I created a basic filesystem with busybox, and then added jikes (ver
Afterwards compiled and installed Kaffe ver 1.1.6 with the following
configuration -

./configure --prefix=/usr --without-x --without-classpath-gtk-awt

Created a simple hello world application -
class HelloWorld {
  public static void main (String[] args) {
      System.out.println("Hello, World!");

# javac HelloWorld.java
# java HelloWorld
Couldn't find or load essential class `java/lang/Object'
java.lang.ClassNotFoundException java/lang/Object

Can you please guide me how to fix the above error?
I searched the mailing list and found somebody had exactly the same
issue; but he never got answered.


I tried also setting CLASSPATH environment variable to rt.jar. Other
links in the Internet claims that CLASSPATH should point to
Klasses.jar[zip]; but this seems to be for older versions of Kaffe?

I tried also Kaffe on a native x86 box and got the following error
(resembles the above one; while a bit different) -
[root at localhost ]# java HelloWorld
/tmp/HelloWorld java.lang.ClassNotFoundException:
.tmp.HelloWorld not found in


More information about the kaffe mailing list