[kaffe] Kaffe Segmentation Fault

Mike Drozdick mikey66 at comcast.net
Wed Jun 21 00:41:45 PDT 2006


I am running Kaffe 1.1.7.

I reverted to gcc 3.4.5, worrying about 4.1.1.
If I did it right it should eliminate compiler as an issue.

I modified my build procedure to the following:
CC=gcc-3.4.5 ./configure
gmake install

It seemed as if the build was using gcc 3.4.5 as it should.
Still, no luck.

Might some tool other than gcc be causing me grief.
I couldn't think of anything else myself.


-----Original Message-----
From: Michael Koch [mailto:konqueror at gmx.de] 
Sent: Wednesday, June 21, 2006 3:24 AM
To: Mike Drozdick
Cc: kaffe at kaffe.org
Subject: Re: [kaffe] Kaffe Segmentation Fault

On Wed, Jun 21, 2006 at 02:58:30AM -0400, Mike Drozdick wrote:
> Hi.
> I successfully built/installed/tested Kaffe on a i386 linux machine
> CentOS4.3, building with gcc 3.4.5. I tested kaffe with a simple "java
> HelloWorld" and everything worked fine! (The "java" is the kaffe alias.)
> I repeated the exact procedure on another machine running Fedora Core 5,
> building with gcc 4.1.1. Everything built, but when I tried "java
> HelloWorld" I got a Sementation Fault with no additional information. I
> tried MANY experiments altering various <configure> options; no change.
> Suspecting the compiler, I reverted to gcc 3.4.5 as in the successful
> repeated the entire procedure from scratch on the Fedora 5 machine, and
> still got the Segmentation Fault.
> Does anyone recognize this symptom or have any ideas? Any thoughts would
> most welcome.

GCC 4.1 is known to give some headaches. Which version of kaffe have you
tried? 1.1.7 or recent CVS? There are some fixes for GCC 4.1 in CVS.


More information about the kaffe mailing list