[kaffe] Cannot load AWT toolkit

Dalibor Topic robilad at kaffe.org
Sat Mar 25 06:09:20 PST 2006

On Sat, 2006-03-25 at 20:55 +0800, yan wei wrote:
> hi, all
>    i want to install the kaffe with qt, so i configure kaffe like
> this(x86):
> ./configure  --with-kaffe-qt-awt --with-qt-libraries=$QTDIR/lib
> --with-qt-binaries=$QTDIR/lib --with-qtdir=$QTDIR
> --without-classpath-gtk-awt --without-esd --without-alsa
> --disable-debug
> i install kaffe successfully(of course, qt has installed
> successfully). but when i run the kaffe's test:  
> ./WidgetDemo.sh


> oh, it's the gtk error, but i don't select the gtk option when i run
> configure, wha't the matter with it? 
> can some one help me? thanks a lot!

Hi Yan,

You need to tell Kaffe that you are using the qt toolkit instead of the
Gtk one, so that it can use the peerless AWT implementation from Kaffe,
rather than GNU Classpath's AWT code. See FAQ/FAQ.awt for details.

The option in question is -Xkaffe-qt-awt, so running Kaffe with 

kaffe -Xkaffe-qt-awt YourClass 

should work. I hope. ;)

dalibor topic

More information about the kaffe mailing list