[kaffe] Re: Kaffe on MIPS64/Linux

Riccardo riccardo at kaffe.org
Sat May 20 01:17:58 PDT 2006


> I was wondering if anyone has ever tried running Kaffe on a MIPS64/Linux
> system. I tried compiling it (with jikes java compiler) and it told me
> only o32 ABI is supported. When I recompiled everything (including
> jikes) and tried to invoke the VM with a simple "hello, world" .class
> files, it aborts with a message saying "illegal instruction".

well, yes. COmpilation on mipsII/mipsIII/mipsIV was and is regularly  
attempted on IRIX and Linux. Unfortunately my mips linux box is dead (scsi  
hard disk gone....) thus it hasn't been tested since long. But your  
problem reproduces on irix too.
THe short answer is JIT doesn't work if not in o32. Interpreter works for  
me on irix. Porting the jit to the newer ELF modes is not a trivial work  
(and without breaking current o32 support). Probably the first best bet  
would be n32 before ever thingking of n64 (I personally think that a 64bit  
JVM doesn't make big sense).

I must add that together with Guilhem I attempted to build the o32 jitter  
on irix by forcing o32 code generation from gcc, while kaffe built it  
still was broken and this is "strange" at best. Probably some bit-rot  
I think to remember that linux can't build/run o32 binaries? I am not even  
sure what kind of "elf" linux mips elf is.

Thus currently, everything is under hold. I need Guilhem's help and irix  
needs to be resuscitated in o32 mode first. Then work on n32 can be  
attempted. Then if my linux box gets a new scsi hard disk (and perhaps  
some ram) development there could continue there too. Linux had problems  
also because gdb was shakey.
Of course I can't gaurdantee that even interpreter works on linux/mips  
sice it wasn't tested since months. The best bet is as always jthreads  
+ intrp.


More information about the kaffe mailing list