[kaffe] new problem!

vlad vlad666 at web.de
Sun Oct 29 07:16:30 PST 2006

Thank you for your help Guilhem!
I've installed those packages and ./configure functioned so far!

Anyway 'make' did not finish later without errors ...
In the directory 'libraries/javalib/vmspecific' make fails to find 
"classdist_vminterface.stamp" required by the "kaffe-vminterface.jar" 
(target). Is there any special config parameter which I have missed, or 
something like that ??? I looked into the Makefile and discovered this:

$(CLASSFILE): classdist_vminterface.stamp
        rm -f $(CLASSFILE)

I cannot find any target 'classdist_vminterface.stamp' ?!?!
Is it normal, that the JAR-CMDs point to a non existent 'lib' directory 
in libraries/javalib/vmspecific/Makefile ? For example:


would be (according to the values of the variables):

/usr/bin/fastjar cf kaffe-vminterface.jar -C lib org

but lib does not exist there!

What goes wrong here? Of course I could easily change the value of 
LIBDIR=. (current dir) and probably it would function...



Guilhem Lavaux wrote:
> Hi Vlad,
> If you use --disable-gconf-peer your problem should vanish. But if you
> have ubuntu 6.06 then you should be able to install the development
> package of gconf2 and gtk using
> apt-get install libgconf2-dev libgtk2.0-dev
> Regards,
> Guilhem.
> vlad wrote:
>> Hello,
>> I've fixed my previous problem so far by using --disable-gtk-peer with
>> configure. Finally I used the following configuration on "./configure":
>> ./configure --build=i686-linux --enable-xscale --without-x
>> --disable-alsatest --disable-esdtest --disable-sound
>> --enable-pure-java-math --without-classpath-gtk-awt
>> --without-kaffe-qt-awt --without-kaffe-x-awt
>> --with-threads=unix-pthreads --with-engine=intrp --enable-debug
>> --enable-xdebugging --disable-boehm-gc-configuration
>> build_alias=i686-linux --enable-ltdl-convenience --disable-core-jni
>> --disable-examples --cache-file=/dev/null --srcdir=. --disable-gtk-peer
>> --enable-gcj
>> I am not sure about the rightness of those options according to my
>> system configuration. Anyway I got a new error:
>> checking for pkg-config... /usr/bin/pkg-config
>> checking for gconf-2.0 >= 2.11.2... Package gconf-2.0 was not found in
>> the pkg-config search path. Perhaps you should add the directory
>> containing `gconf-2.0.pc' to the PKG_CONFIG_PATH environment variable No
>> package 'gconf-2.0' found
>> configure: error: Library requirements (gconf-2.0 >= 2.11.2) not met;
>> consider adjusting the PKG_CONFIG_PATH environment variable if your
>> libraries are in a nonstandard prefix so pkg-config can find them.
>> My system is:
>> Ubuntu 6.06.1 LTS
>> Linux version 2.6.15-27-386
>> gcc version 4.0.3 (Ubuntu 4.0.3-1ubuntu5)
>> autoconf (GNU Autoconf) 2.59
>> automake (GNU automake) 1.4-p6
>> pkg-config --version = 0.20
>> gconf2  (2.14.0) is also installed
>> ...
>> please tell me if you know, how I could fix this one.
>> Thanks in advance, Regards
>> Vladimir
>> _______________________________________________
>> kaffe mailing list
>> kaffe at kaffe.org
>> http://kaffe.org/cgi-bin/mailman/listinfo/kaffe

More information about the kaffe mailing list