[kaffe] Building Kaffe!

vlad vlad666 at web.de
Mon Oct 30 11:14:33 PST 2006


Because I am getting more and more obscured by even more details, I 
wanna tell you what I did to attain here:

- first I checked out the 'kaffe' module from "cvs.kaffe.org:/cvs/kaffe" 
(got it not from the ftp source)

- when running ./configure it fails with the message: "configure: error: 
GTK+ peers requested but no X library available" ... to fix this one I 
run configure with
"--without-x --without-classpath-gtk-awt --without-kaffe-qt-awt 
--without-kaffe-x-awt --disable-gtk-peer" ...
now configure succeeds! (is there any other fixup?)

- when running 'make', it enters into 
"libraries/javalib/external/classpath/lib" and fails on:
"Adding java source files from srcdir '..'.
 Adding java source files from VM directory ../vm/reference
 F  -bootclasspath '' -extdirs '' -sourcepath '' --classpath    
-d . @classes
 make[3]: F: command not found
 make[3]: *** [compile-classes] error 127"

- In '/libraries/javalib/external/classpath/' I've found another 
configure, which I executed with the same parameters as described above! 
I run make again and it led to the previous error with the .stamp target

Now I have cleaned all Makefile.in files in the tree and updated then 
with "cvs -qz3 update" ...
Each make call leads now to the "make[3]: F: command not found" error as 
described above ...

Do you have an idea how I could manage it? What happens?
Thank you for any reply in advance!

Best Regards


Guilhem Lavaux wrote:
> Hi,
> The target to produce this .stamp file is present in
> libraries/javalib/vmspecific/Makefile.in (and Makefile too of course).
> It is generated by newer automake. Maybe automake has tried to rebuild
> your Makefiles ? I suggest you clean up Makefile.in in your tree and
> reupdate from cvs using 'cvs -qz3 update' and see if it improves the
> situation.
> Regards,
> Guilhem.

More information about the kaffe mailing list